FORUMS

Top Earners This Week
1
Burnsy x 95 Points: 9,032 Lv 30
2
Space Baby Points: 5,517 Lv 30
3
.PKZ. Points: 4,429 Lv 30
4
adminerest Points: 4,331 Lv 30
5
erechtheus Points: 3,202 Lv 26
6
Hal_K0 Points: 2,960 Lv 30
7
liuted Points: 2,430 Lv 23
8
jonathan09h Points: 2,392 Lv 22
9
zen6009 Points: 1,990 Lv 19
10
lfcdtl Points: 1,846 Lv 30

Steam Quests doesn't work

  • 9

I've linked my steam account to my Alienware account, but when I check the game, it just refreshes the page. I have played Dota 2 and apex for more than an hour and I haven't received any arp. Does anyone know a fix for this?

Replies • 6

Try this, credit to bigboss-62.

The problem was related to my profile settings on Steam. In Game Details, the checkbox "Always keep my total playtime private even if users can see my game details" was checked, so playtime can't be reclaimed on AWA.

 

I unchecked it, and now BF2 is found on my account.

 


My Steam account won't link.  Can anyone advise a quick fix?


Try re-checking every requirements are done, after that launch the game from the website.


shdw1011 said:

My Steam account won't link.  Can anyone advise a quick fix?

I have same problem with linking, but i fixed it. Created another steam account, linked it, after that i was lucky enough to link my main steam.

Actually, other problem still not fixed at all. I can't even start steam quests.... Downloading game, launching it through link that provided in quest, waitinig for 2-3 hours, and nothing, button "check game" don't working.

edited