FORUMS

Top Earners This Week
1
Jecf04 Points: 892
2
AlexeyHolms Points: 602
3
Incariuz Points: 532
4
ieve97 Points: 479
5
PCR Points: 446
6
Hallowed Be Thy... Points: 429
7
officialSinistr... Points: 427
8
arkt-13 Points: 422
9
Cdcorky Points: 416
10
Mr. Pokeylope Points: 415

To all Steam Questers, HOW?! (DBD Community Event)

Interstellar
  • 4

I am never able to join these Steam quests. How are people able to get this unicorn "Launch" button to show up? It's frustrating. I know this isn't a rare issue as I got all these ideas from older threads months ago. There is a reason why the hours in the DBD community event is still so low because Alienware has yet to fix this common issue that many of us have.

All the things I have tried but still haven't worked:

Link a new Steam account.

Clearing browser cookies.

Steam public profile of every setting.

Using browsers Firefox/Chrome.

Playing said quest game for hours before trying again.

Removed/disabled adblock and tracking protections on the browser.

Edited
Replies • 17

Interstellar
Milkyshakes said: 3h

Make sure your steam Playtime hours isn't hidden either.

That settings is unchecked. So yes playtime hours are visible.


Kuang Grade Mark Eleven

From my experience AWA content works better with browsers based on the Chromium engine. To eliminate any possible browser conflicts from the equation try a fresh install of e.g. Edge or Brave and tell us how that goes.


Planetary

It might be your settings on your computer, have you tried on another computer?


Planetary

Since you have chrome:

Open an incongnito window to open the awa quest page, you'll have to log in again. Then Temp turn off/pause any adblockers you have (adblock plus, uBlockOrigin etc) on that incognito window. The reason you're trying this in an incognito window is to see if any extensions you have running in Chrome are interferring with getting this working.

You said you linked a NEW steam account to awa, so check that your details are public on that new steam account etc again, yeah annoying I know but do it anyway. Make sure that THIS steam account owns Dead By Daylight. When everything is good to go and the event is live you'll see the Launch Game button.

This is what the buttons looks like in images on the event page:

 1. You're logged in to the AWA site and the event is planned/running

 2. Accounts are not linked correctly &/OR your Steam profile is private &/OR the steam account you linked doesnt own DBD. (if you're sure this steam account owns it, you can try pressing the Check Games button for awa to rescan your games list)

 

 

edited

Resident Misanthrope

If it's a new Steam account, it may be a limited account if you haven't spent at least $5 on something.


Planetary

Apologies, I cant seem to edit the last post to add images so here's the rest:

 3. This appears when the event has started, AWA sees that you own DBD and your accounts are linked correctly. You're good to go. Pressing this button will launch steam and open DBD, yay! Note that if you change back & forth from private to public profiles on steam (as I do) it can take anywhere up to half an hour for AWA and Steam to handshake.  Dont forget to close the game when you're done playing for your hours to be counted.

I hope this helps you and anyone else having issues.

 


Planetary
BackcountryDave said: 7m

If it's a new Steam account, it may be a limited account if you haven't spent at least $5 on something.

This is a good point that I missed! Thanks!

(Though perhaps not an issue if you bought DBD directly from Steam.)

edited

Planetary

Are you able to gain ARP when you try Steam Quest games?

Wait, is your question about DBD event not showing the Start Quest - join button, or you mean you can't start join any Steam Quest games at all?

edited

Interstellar

One thing I can tell you is the event doesn't inform you if you are actually recording the hours on the page or not. So maybe it is working, but it's vague about it. You don't *have* to actively join it or not. All you have to do is just connect your account to the event and the community takes care of the rest.

Especially given the rubberbanding in effect, having to even try is moot.

edited